Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 4 of 4

Thread: Multisampling buffers

  1. #1
    Intern Contributor
    Join Date
    Sep 2012
    Posts
    76

    Multisampling buffers

    Greetings!
    I ran multisamp.c from the red book in my Win 7/MS Visual Studio 2010 environment and it tells me

    number of sample buffers is 0
    number of samples is 0

    which I guess means multisampling is disabled (visually too I see no antialiasing happening).

    My card is a GeForce 9600 GT and the Antialiasing - Transparency option in the Nvidia control panel is set to Multisampling.

    So, question: what do I need to do to activate multisampling/buffers? Incidentally, I am using glut-3.7.6 from xmission.com. If this is the cause of the problem I will upgrade to FreeGlut, but would rather leave my system as it is if it's not.

    Thanks in advance,
    Sam

  2. #2
    Senior Member OpenGL Guru
    Join Date
    May 2009
    Posts
    4,948
    Using GLUT for anything is always a problem. FreeGLUT is a drop-in replacement that also allows you to create multisample contexts, among many other things.

  3. #3
    Intern Contributor
    Join Date
    Sep 2012
    Posts
    76
    Thanks, Alfonse.
    Just to be sure, GLUT doesn't support making multisampling contexts, right?

  4. #4
    Intern Contributor
    Join Date
    Sep 2012
    Posts
    76
    Quote Originally Posted by sam_thedancer View Post
    Thanks, Alfonse.
    Just to be sure, GLUT doesn't support making multisampling contexts, right?
    Checked myself: the answer is yes. I switched to freeGLUT and multisampling works now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •