Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 2 of 2

Thread: Interleaved VBO with mixed types fails on AMD FirePro M5950

Hybrid View

  1. #1
    Junior Member Regular Contributor CatDog's Avatar
    Join Date
    Mar 2006
    Location
    Germany
    Posts
    226

    Interleaved VBO with mixed types fails on AMD FirePro M5950

    Hi Folks,

    just spend two days on debugging my code on a customers' HP Elitebook 8560w with AMD FirePro M5950. This GL code worked for ages, on every hardware I came across. It's simple:

    Given an interleaved array of positions and texcoords [x0, y0, u0, v0, x1, y1, u1, v1, ...] the following code doesn't work on the Elitebook, if the positions are of type GL_INT and the texcoords are GL_FLOAT:

    glBindBuffer( GL_ARRAY_BUFFER, MyVBO );
    glVertexPointer( 2, GL_INT, 16, 0 );
    glTexCoordPointer( 2, GL_FLOAT, 16, 8 );

    No error is generated, but nothing is rendered. After casting the positions to floats and using GL_FLOAT in glVertexPointer it works as expected.

    Just wanted to let you know. Maybe some AMD guy should have a look at this.

    CatDog

  2. #2
    Member Regular Contributor
    Join Date
    May 2000
    Location
    Philadelphia
    Posts
    285
    I would suggest you posting it on AMD's website instead. I don't think anyone at AMD is paid to read this forum.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •