Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 2 of 2

Thread: Impossible Texture Issue?

  1. #1
    Junior Member Newbie
    Join Date
    Mar 2000
    Location
    College Station
    Posts
    1

    Impossible Texture Issue?

    Hello,

    I believe the solution to my problem is
    to write my own texture mappping routines, but I hope someone can tell me I am wrong.

    I have a materials editor that has a list of loaded materials and used textures.
    I want to display the texture maps in the viewport. The effect I want is alpha blending of the texture in decal mode with the object's color. To my knowledge this would require me to have a separate texture for each object, because while textures may be common to objects, their transparency may differ by material. Is there a way to get this effect by explicitly setting a blend
    factor instead of packing the texture with
    a constant alpha value?

    With thanks....

    Dave Eberle

  2. #2
    Junior Member Regular Contributor
    Join Date
    Mar 2000
    Location
    Germany
    Posts
    184

    Re: Impossible Texture Issue?

    Hi there!

    Hm, sorry I'm not really sure if I got it, but why don't you try the following:

    Generate a texmap using the object's color
    and use mutlitexturing to combine it with
    the selected texture.

    Just a thought.

    Regards,

    LG

    May the vector be with you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •