Odd. Not sure why it works then. Does it make any difference that #extension GL_EXT_gpu_shader4 : enable is defined?

EDIT: Ah, yes, seems it does: https://www.khronos.org/registry/Ope...pu_shader4.txt

That must have been what I was looking at before.