Hey guys!

This is my first time in this forum. As the title already suggests, I have a problem with ARB_bindless_texture. The following code will be in Java but there is basically no difference to the C++ code as the OpenGL interface looks nearly the same everywhere.

If I get a resident handle from a texture like this:
Code :
this.myTextureHandle = ARBBindlessTexture.glGetTextureHandleARB(myTexture);
ARBBindlessTexture.glMakeTextureHandleResidentARB(myTextureHandle);

And get the uniform location like this (program named fragProgram, because of separate shader programs):
Code :
this.uniformTexture = GL20.glGetUniformLocation(fragProgram, "textureMap");

And bind it like this:
Code :
ARBBindlessTexture.glProgramUniformHandleui64ARB(fragProgram, uniformTexture, myTextureHandle);

then all the samples I get from this texture are 0!

In the shader I have:
Code :
#extension GL_ARB_bindless_texture : require
layout(bindless_sampler) uniform;
 
uniform sampler2D textureMap;

and I'm using it just as always. But if I bind the texture with the following instead of glProgramUniformHandleui64ARB it works:
Code :
GL13.glActiveTexture(GL13.GL_TEXTURE0);
GL11.glBindTexture(GL11.GL_TEXTURE_2D, myTexture);
GL41.glProgramUniform1i(fragProgram, uniformTexture, 0);

The texture I'm using is bound to a framebuffer but I tested it with another texture I loaded just for that and it didn't work either:/

I really need to get this issue removed because I want the samplers to be in a uniform or shader storage buffer object:/

Please help me c:

cbOP_