Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 2 of 2

Thread: Texture not updating in openGL

  1. #1
    Junior Member Newbie
    Join Date
    Feb 2018
    Posts
    14

    Texture not updating in openGL

    Hi,

    I have a piece of code where I am changing the image for the texture. Even though the paint function(Qt) of the class is called, it doesn't change. I can remove and bring it back, but the changes are not visible unless I destroy and recreate the object. What might I be missing?

    Thanks

  2. #2
    Senior Member OpenGL Guru Dark Photon's Avatar
    Join Date
    Oct 2004
    Location
    Druidia
    Posts
    4,569
    I haven't worked with OpenGL under Qt lately. Have you tried searching for some tips and tutorials based on the Qt interface you're using? For instance:

    * https://stackoverflow.com/questions/...-opengl-and-qt

    From a pure OpenGL perspective: 1) Update the texture (e.g. using an FBO), 2) Render the texture onto some geometry in the window framebuffer or "blit" the texture directly onto the window framebuffer, 3) Tell the windowing system that the window framebuffer is ready to display. However, you need to learn how the Qt interface you're using is making use of OpenGL to make the best use of it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •