Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 2 of 2

Thread: glxinfo shows LibGL error

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Newbie Newbie
    Join Date
    Nov 2017
    Posts
    1

    glxinfo shows LibGL error

    I am running Cento 7.4. And when I run glxinfo | grep "OpenGL version"
    it gives me output as following:
    +++++++++++++++++++++++++++++++++++++++
    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast
    OpenGL version string: 1.4 (2.1.2 NVIDIA 340.102)
    +++++++++++++++++++++++++++++++++++++++
    yzhao@puccini:/home/yzhao$ sudo find /usr -iname "*libGL.so*" -exec ls -l -- {} +
    [sudo] password for yzhao:
    lrwxrwxrwx 1 root root 14 Aug 26 17:17 /usr/lib64/libGL.so -> libGL.so.1.2.0
    lrwxrwxrwx 1 root root 14 Aug 26 17:16 /usr/lib64/libGL.so.1 -> libGL.so.1.2.0
    -rwxr-xr-x 1 root root 481320 Aug 3 21:27 /usr/lib64/libGL.so.1.2.0
    lrwxrwxrwx 1 root root 16 Nov 25 18:11 /usr/lib64/nvidia/libGL.so -> libGL.so.340.102
    lrwxrwxrwx 1 root root 16 Nov 25 18:11 /usr/lib64/nvidia/libGL.so.1 -> libGL.so.340.102
    -rwxr-xr-x 1 root root 1267800 Feb 25 2017 /usr/lib64/nvidia/libGL.so.340.102
    lrwxrwxrwx 1 root root 14 Aug 26 17:21 /usr/lib/libGL.so.1 -> libGL.so.1.2.0
    -rwxr-xr-x 1 root root 562732 Aug 3 21:20 /usr/lib/libGL.so.1.2.0
    ++++++++++++++++++++++++++++++++++++++

    Any solution to solve this issue would be highly appreciated!

    -Yi

  2. #2
    Senior Member OpenGL Guru Dark Photon's Avatar
    Join Date
    Oct 2004
    Location
    Druidia
    Posts
    4,167

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •