Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 5 of 5

Thread: Performance problem PBO + glCompressedTexSubImage3D + Texture Array

Threaded View

  1. #1
    Junior Member Newbie
    Join Date
    Jul 2013
    Posts
    10

    Performance problem PBO + glCompressedTexSubImage3D + Texture Array

    Hello there,

    i've a problem with updating a texture array with compressed data per glCompressedTexSubImage3D.

    I have an PBO which stores the compressed data, which i want to use to update a 2D array texture.
    Unfortunately the updating process is very slow and need 100 ms.
    The upload process to the GPU is already finished when i call glCompressedTexSubImage3D, because i use
    fences to check for that.

    What's odd is the fact, that this problem does only occur if i create an array texture with more then one layer.
    With one layer it works like a charm. If i create an array texture with let's say 2 layers, the problem even occurs for the first layer.
    My driver version is 331.38 and i use linux.

    I hope someone can tell me what i am doing wrong or at least confirm that this is a driver bug.

    Edit: Oh i forgot to mention that i'm using a Debug context and that no errors are thrown.
    Last edited by t_guen03; 06-07-2014 at 09:22 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •