Part of the Khronos Group

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Password for Subversion repository of XML API Registry

  1. #1
    Newbie Newbie
    Join Date
    Jun 2013

    Password for Subversion repository of XML API Registry

    Note 1: I don't know if this is the correct sub-forum for asking this question. Moderators are allowed to feel free to move this thread where it fits, if necessary.
    Note 2: Because the forum software denies me to post otherwise, I had to obfuscate the URLs a little bit (remove spaces to deobfuscate them). Sorry for the inconvenience. :-(


    According to
    > h ttp://
    "All documents in the registry are available from the Khronos Subversion server using anonymous public access."

    In the Readme file ( page 4, section 2 you can read:

    "However, to modify the XML database or the generator scripts for other purposes,
    you’ll need to install a Subversion client and download the registry subrepository at

    h ttps://"

    I tried to put this URL into my subversion client (TortoiseSVN 1.8.0), but it keeps me asking for username/password. I tried lots of sensible username/password combinations, as leaving these fields empty, anonymous/email_adress etc. None is accepted.

    So: what is an accepted username/password combination for checking out the registry subrepository by a subversion client anonymously?
    Last edited by Wolfgang Keller; 06-26-2013 at 04:28 PM.

  2. #2
    Advanced Member Frequent Contributor
    Join Date
    Apr 2010
    Hmm, for me "svn checkout" works and never asks for username/password. I'm not terribly familiar with TortoiseSVN, is there perhaps a checkbox to tell it you want an anonymous checkout?

  3. #3
    Newbie Newbie
    Join Date
    Jun 2013
    Based on your comment, carsten neumann, tried using the command line version with the same command ("svn checkout"). The server still asked for username/password.

    But then I tried the following combination (I don't know how I came to the idea to try this combination):

    Username: anonymous
    Password: anonymous

    This combination was accepted - so: problem solved.

    Perhaps it should be added to the documentation that this username/password should be used for anonymous access...

    EDIT: I assume the reason why you aren't asked for username/password is that it's already stored on your computer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts