Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 10 of 10

Thread: GLAPI fails in glu.h

  1. #1
    Junior Member Newbie
    Join Date
    Jan 2011
    Posts
    12

    GLAPI fails in glu.h

    Hi, I am a newbie in OpenGL. I tried to learn OpenGL on Microsoft Visual Studio. However, I got an error about GLAPI stuff in glu.h like indicated in the following site
    http://www.sfml-dev.org/forum/viewto...3807237e2abb8c

    Please tell me how that I can solve this problem

  2. #2
    Advanced Member Frequent Contributor
    Join Date
    Mar 2009
    Location
    Karachi, Pakistan
    Posts
    810

    Re: GLAPI fails in glu.h

    Perhaps your headers are not ordered properly.
    Try changing the order.
    Regards,
    Mobeen

  3. #3
    Junior Member Newbie
    Join Date
    Jan 2011
    Posts
    12

    Re: GLAPI fails in glu.h

    Which header in which files ? I am pretty much confused since I just follow the code in OpenGL superbible 5th edition.

  4. #4
    Advanced Member Frequent Contributor
    Join Date
    Mar 2009
    Location
    Karachi, Pakistan
    Posts
    810

    Re: GLAPI fails in glu.h

    OK do this get the latest svn version from here and see if this sorts out ur problem.
    Code :
    svn checkout [url]http://oglsuperbible5.googlecode.com/svn/trunk/[/url] oglsuperbible5-read-only
    Regards,
    Mobeen

  5. #5
    Member Regular Contributor
    Join Date
    Oct 2010
    Location
    France
    Posts
    458

    Re: GLAPI fails in glu.h

    Never forget, on windows, to include windows.h before any gl/glu/glut headers.

  6. #6
    Junior Member Newbie
    Join Date
    Jan 2011
    Posts
    12

    Re: GLAPI fails in glu.h

    Thank you very much. I'll try.

  7. #7
    Junior Member Newbie
    Join Date
    Jan 2011
    Posts
    12

    Re: GLAPI fails in glu.h

    I have put <windows.h> on the top, but it still doesn't work.

  8. #8
    Advanced Member Frequent Contributor
    Join Date
    Mar 2009
    Location
    Karachi, Pakistan
    Posts
    810

    Re: GLAPI fails in glu.h

    Assuming that u are using the latest svn release, could u please let us know which chapter and what project you are running.
    Regards,
    Mobeen

  9. #9
    Junior Member Newbie
    Join Date
    Jan 2011
    Posts
    12

    Re: GLAPI fails in glu.h

    The first chapter <creating block>. I also tried to use VS2010 and CodeBlock. Although the errors are different.

  10. #10
    Junior Member Newbie
    Join Date
    Jan 2011
    Posts
    12

    Re: GLAPI fails in glu.h

    It actually works on VS2008 and Codeblocks. But for codeblocks(Linux), we have to manually edit the makefile.
    makefile should be an easy task to do.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •