Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: No hard / only software rendering

  1. #1
    Junior Member Newbie
    Join Date
    Sep 2002
    Location
    Amsterdam
    Posts
    6

    No hard / only software rendering

    I am developing on mac OS 10.1.3 and I can only get software rendering. I use sample code from apple's "Carbon Setup GL". Running in fullscreen mode 640x480 16bit . When I set the attributes to fAcceleratedMust or AGL_ACCELERATED I get the messages "Renderer check failed" or "Could not find valid pixel format" ????

    Can it have something to do with my hardware: ( iMac 333mhz 192mb 6mb video) ??

    BTW not any renderer has video ram.

  2. #2
    Advanced Member Frequent Contributor
    Join Date
    Dec 2001
    Location
    Wellington, New Zealand
    Posts
    544

    Re: No hard / only software rendering

    MacOSX 10.1.3 (and less) don't have hardware acceleration for ATI Rage Pro graphics cards, which from your description is probably what you have.

    Rumor has it that 10.2 will provide OpenGL acceleration for those cards, but I wouldn't hold my breath...

  3. #3
    Junior Member Newbie
    Join Date
    Sep 2002
    Location
    Amsterdam
    Posts
    6

    Re: No hard / only software rendering

    thanks,

    I hold my breath for 10.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •