Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: "unknown error loading module"

  1. #1
    Junior Member Newbie
    Join Date
    May 2002
    Posts
    2

    "unknown error loading module"

    I have load "glx" in my config file but my X log says no module path specified when it tries to load the glx. I am a newb but I got this far

    this is mandrake8.2 with a GF4TI4400 and 512DDR and SoundblasterAudigy

  2. #2
    Junior Member Newbie
    Join Date
    May 2002
    Posts
    2

    Re: "unknown error loading module"

    My config is set right but when I go to startx I get an error "unknown error loading module" whitch I traked down to glx and this error : Segmentation Fault(core dumped)

    Can anyone help

    GfTi4400 512DDR Mandrake 8.2 fresh install
    drivers loaded from tar and rpm give the same error

  3. #3
    Intern Contributor
    Join Date
    Mar 2002
    Posts
    61

    Re: "unknown error loading module"

    Several things you should check :

    1- What is your XFree version ?
    (4.x and more allow 3D acceleration).

    2- X serveur loads XF86config-4 when you have XFree >= 4.x and not XF86config (I had these dumb problem once... )

    3- "load "glx"" has to be set in the "Module" section of XF86Config-4.

    4- change your "nv" drivers to "nvidia" in XF86Config-4.

    if it doesn't work, well... try to uninstall glx drivers AND kernel drivers for your card and install first the kernel and then GLX.
    (NVidia's RPMs work fine with Mandrake 8.2).

    I hope it'll help...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •