Try updating your video drivers. GeForce 8 and later hardware is capable of OpenGL 3.3 (any hardware which supports DirectX 10 should be physically capable of supporting OpenGL 3.3). The GeForce 9...