Minecraft 1.7.2 just came out and i want to play, but i have two problems:

1. I need a better graphics card (im just taking it to best buy so im good there)
2. It keeps saying i need OpenGL 2.1...