Just:


Run your package manager (LINK),
Tag the packages for glfw development (probably libglfw3 and libglfw3-dev) (LINK), and
Click OK to install them.

Now you're ready to compile and...