Mobility Radeon HD 5xxx should be OpenGL 3.3 compatible. Try to install some newer Catalyst drivers.
Before reinstalling drivers, you could check the current version with OpenGL Extension Viewer.