Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: phil0stine

Search: Search took 0.00 seconds.

  1. Replies
    4
    Views
    484

    Turns out, both textures were setup incorrectly,...

    Turns out, both textures were setup incorrectly, with


    glTexImage2D(GL_TEXTURE_2D, 0, GL_RGB32F, width_, height_,
    0, GL_RGB, GL_FLOAT, NULL);

    instead of

    ...
  2. Replies
    4
    Views
    484

    That was an artifact of the many permutations I...

    That was an artifact of the many permutations I went through to before posting, although I don't know whether it's best to bind to different texture units or overwrite texture unit 0.

    Also:


    ...
  3. Replies
    4
    Views
    484

    render textures with blend

    Simple setup, fbo with 2 textures which I want to render to the default framebuffer with blending. If I render one or the other texture, the screen renders what I would expect, including alpha...
  4. Replies
    11
    Views
    1,952

    My problem was really 2 fold. One was properly...

    My problem was really 2 fold. One was properly projecting a 3D scene to an exact recreation of what a camera would see from a given viewpoint (which my last post resolved, and which requires...
  5. Replies
    11
    Views
    1,952

    Finally got it. As mentioned before, and shown...

    Finally got it.

    As mentioned before, and shown https://gist.github.com/astraw/1341472#file_projection_math.py

    the ModelView matrix is not identity, but rather identity with flipped y and z...
  6. Replies
    11
    Views
    1,952

    That would be the creation of the projection...

    That would be the creation of the projection matrix, which I think is the root of my problem. I have tried alternative formulations by hand, based on some of the following blogs, without success. ...
  7. Replies
    11
    Views
    1,952

    I have made a min-working example to demonstrate...

    I have made a min-working example to demonstrate the root of my problem, which is the proper projection of points from a cloud to an image, where the projection matches the image that generated the...
  8. Replies
    11
    Views
    1,952

    Ok, I thought a viewport applied to each fbo. I...

    Ok, I thought a viewport applied to each fbo. I hesitate to go too deep in the weeds of my design (although if anybody is willing to help me with that I also would appreciate it), I actually have 2...
  9. Replies
    11
    Views
    1,952

    Thanks to both. GClements, you are absolutely...

    Thanks to both. GClements, you are absolutely right that was an obvious problem. I still see an offset, and I am convinced it has to do with my viewports as Slience mentions.


    Since I am...
  10. Replies
    11
    Views
    1,952

    Blit vs Render from texture

    I would like to get a possible explanation for a discrepancy in the resulting output when Blitting versus sending a texture to a shader for simple rendering.

    My blit operation is simply sending...
  11. Replies
    2
    Views
    339

    Thanks for the tip on the debug context (I have...

    Thanks for the tip on the debug context (I have appropriate error checking in my actual program), that will be very helpful going forward.


    This would be perfect for my project. So, please tell...
  12. Replies
    2
    Views
    339

    FBOs for color picking

    Hi all, I would like to use the color method for picking with a separate FBO. I have run into the problem that, even though AFAICT I have setup the FBO identically to the default framebuffer, which...
Results 1 to 12 of 14