Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: davoring

Search: Search took 0.00 seconds.

  1. Trouble passing Uniform Buffer Objects to shader

    Hello,

    I'm trying to use Uniform Buffer Objects to pass arbitrary data as a float array to a shader, and I'm having some trouble with that. I can get it to run, but I don't get the results I...
  2. Replies
    3
    Views
    474

    Thanks or the very informative answer. I think I...

    Thanks or the very informative answer. I think I understand most of it. :)

    After some more research and fiddling, I think I got it.

    I changed the bit of code from



    color =...
  3. Replies
    3
    Views
    474

    Help with basic lighting in shader

    Hello,

    I'm trying to make a shader that works as close as possible to the fixed functionality in terms of lighting, and I'm having some difficulties with that. My problem is that the end result is...
  4. Replies
    2
    Views
    481

    Woohoo, that did the trick! Thank you!

    Woohoo, that did the trick! Thank you!
  5. Replies
    2
    Views
    481

    Problem with texture transparency

    Hello,

    I've started playing with textures that have transparent parts in them, and I'm having some difficulties getting them to display properly. My problem is that I can't get the transparent...
  6. Replies
    5
    Views
    973

    Good stuff, thanks again. :)

    Good stuff, thanks again. :)
  7. Replies
    5
    Views
    973

    Adding glEnable(GL_COLOR_MATERIAL) has improved...

    Adding glEnable(GL_COLOR_MATERIAL) has improved things in that the brightness of my triangles now depends on their angle. However, I still have a problem: all triangles appear as if they were drawn...
  8. Replies
    5
    Views
    973

    Perfect, thanks!

    Perfect, thanks!
  9. Replies
    5
    Views
    973

    Lighting issues (very basic)

    Hello,

    I'm getting started with opengl, and I'm facing issues with the lighting. My problem is that I'm drawing a red shape, but it is rendered white. I'm sure I missing something elementary...
    ...
Results 1 to 9 of 9