I think the idea of the ARB_compatibility extension is a good one. However, I think this extension should be revised to contain a new token for "enabling" compatibility. For instance:

// enable...