GeForce 6150SE

This belongs to the GeForce 6 series and so will never support any OpenGL version higher than 2.0 or 2.1. It's also an entry-level part and so will have incredibly poor performance...