PDA

View Full Version : Please help: Issue with mipmapping/rendering of track texture



joakimkasper
11-04-2017, 09:00 AM
Terribly looking track texture rendering.

Graphics Card: Nvidia ASUS ROG Strix GTX 1080ti 11G
Monitor: 34" Samsung CF791 at 3440x1440 resolution and 100hz


Hi all,

I have a rendering issue in a game called Transport Fever where the rendering of the track texture (sleeper) is terrible (see screenshots attached that show a very abrupt transition where the texture goes from dark brown to something much brighter akin to skin-color). I mean what? Not sure where the problem is. Mipmapping shouldn't really be causing this. The roads in the game do not have this issue. Just the track. Doesn't make sense to me. Seems like after a certain distance, the track texture is rendered differently. Almost like strong brightness is added to the texture.

How can I resolve this? Would really appreciate any help here. Thank you.

Here is the OpenGL for the sleeper (mtl file):



function data()

return {
params = {
map_color_reflect = {
compressionAllowed = true,
fileName = "tracks/sleeper.tga",
magFilter = "LINEAR",
minFilter = "LINEAR_MIPMAP_LINEAR",
mipmapAlphaScale = 0,
type = "TWOD",
wrapS = "REPEAT",
wrapT = "REPEAT",
},
map_env = {
compressionAllowed = true,
fileName = "c.tga",
magFilter = "LINEAR",
minFilter = "LINEAR",
mipmapAlphaScale = 0,
type = "CUBE_MAP",
wrapS = "REPEAT",
wrapT = "REPEAT",
},
props = {
coeffs = {
1.0, 1.0, .2, 10.0
},
},
},
type = "REFLECTIVE",
}
end