PDA

View Full Version : GL3: non-GL3 version number: 1.0



pixelord
10-11-2017, 09:28 PM
Hi guys,
I am working on a code that uses a third party sdk.
That third party SDK uses OSG library to render some graphics stuff and OSG(Open Scene Graph) uses OpenGL.
Now the thirdparty library has a function that initialises OSG stuff, something like that osgInit();

Whenever, I call osgInit I get this error message,

GL3: non-GL3 version number: 1.0

My question is what does it mean actually?
Does it mean that I don't have OpenGL version 3 library in my development environment and it requires OpenGL 3.0?
Can anyone give me a direction how to fix this issue?
If OpenGL 3 is required, how to get OpenGL 3 header and lib?


Thanks,
Mahmud

Silence
10-12-2017, 12:05 AM
This error message is really weird. It in fact suggest that you don't have OpenGL 3, but you would at least have had OpenGL 1.1 (to my opinion).

You'll certainly have more chance here (http://forum.openscenegraph.org/).