PDA

View Full Version : Color instructions get ingnored when the generator file is in subfolder



LSCHM26
04-05-2017, 01:01 PM
I have put the c and h files (except the one with the main) and shaders in subfolders (I also have an extra folder for the compiled files) and it compiles and runs and the shade is displayed - but except the background everything is white. What can I do here?
By the way is there some color library i can download so the colors have names I can individually understand and aren't just some floats in an array.

Dark Photon
04-05-2017, 05:08 PM
I have put the c and h files (except the one with the main) and shaders in subfolders (I also have an extra folder for the compiled files) and it compiles and runs and the shade is displayed - but except the background everything is white. What can I do here?

Try reducing your program to the bare minimum (e.g. allocating your window and glClear()'ing the window to some constant color). Built up from there. When "strange things happen", you'll know what caused it.

It can help to check your intermediate versions into a version control system so you can trivially go back and see where things went wrong.



By the way is there some color library i can download so the colors have names I can individually understand and aren't just some floats in an array.

One helpful source is X11's rgb.txt file:

* http://hans.fugal.net/vim/rgbtxt.html

Of course, you can use any image editor (Gimp, Photoshop, MSPaint, etc.), and it'll let you dial in a color and see what it is.