PDA

View Full Version : Is it okay to use GL3.3 instead of GL4?



oddman621
03-31-2017, 01:12 AM
I have a book(Superbible) which I can learn OpenGL4 from this.

But my Bay-trail laptop only supports 3.3, not 4.0 or above.
(maybe it will support 4.5 with mesa 17.1, but not now...)

I'm worrying about is there any problem between only 3.3 environment laptop and 4.0 or above recommended GL book. Is it okay with these?

Silence
03-31-2017, 01:31 AM
What else can you do ?
As long as you don't use features not supported by your GPU/driver, this will be the same. You will mostly not be able to do any tesselation shaders. Apart from this, news in GL 4.0 will not hurt you at your start point.
Anyway, if you just start, you should not worry about that at all. It might have been more annoying if you had a GL 2 card with a GL 4.5 book.

Here (https://en.wikipedia.org/wiki/OpenGL#OpenGL_4.0) are listed main differences between each versions of OpenGL.

GClements
03-31-2017, 03:35 AM
I'm worrying about is there any problem between only 3.3 environment laptop and 4.0 or above recommended GL book. Is it okay with these?
4.0 didn't really add that much. Some of the later 4.x versions made far more significant changes than those between 3.3 and 4.0.

The main problem is that if something doesn't work, it may not be immediately apparent that it's because of the version. If the problem is that the book uses a function which doesn't exist in 3.3, that's fairly easy to identify. The online reference pages (https://www.khronos.org/registry/OpenGL-Refpages/gl4/) clearly indicate the required version for each function. But newer versions also extend the behaviour of existing functions, and it's much harder to identify when that's an issue.

oddman621
04-05-2017, 12:27 AM
Next release on May 2017, Mesa 17.1, will supports OpenGL 4.0 for Ivy-Bridge and Bay-Trail, by the way. :)