PDA

View Full Version : Hi and sorry for bothering everyone (Ati mobility hd 5000 Series)



kvexino
01-14-2017, 05:06 AM
AMD Graphics Card

ATI Mobility Radeon HD 5470 (5000 series)

Desktop or Laptop System

HP G72 b40sq

Operating System

Windows 7 - 64bit

Driver version installed

AMD-Catalyst-15.7.1-With-DOTNet45-Win7-64bit

Display Devices

Mobile PC Display / Samsung 173KT01-K01

Motherboard

Hewlett-Packard HP G72 Notebook PC

CPU/APU

Mobile DualCore Intel Core i5-480M, 2933 MHz (22 x 133)

RAM

8GB - SK Hynix HMT351S6BFR8C-H9 and SK Hynix HMT351S6EFR8A-PB



I don't know if is the right forum/location to ask for help but maybe I will find some good Samaritans to help me with a huge problem that i cannot solve it by myself.
I have got card name: AMD Mobility Radeon HD 5000 Series
The problem starts when i want to open OpenGL games, i get error such as atiumdag.dll failed to start.
I want to say that i have clean installed latest ati graphic driver which is 15.7.1 for my video card.
Latest driver Name : amd-catalyst-15.7.1-with-dotnet45-win7-64bit.exe
The driver was installed correctly and I am sure 100% because I clean installed windows and the video driver as first driver but still same error.

Now what i want to say is that when i install an old driver Name : ati_catalyst_10.7beta_opengl_es2.0_win7_vista.exe the game starts but
the image in game is shaking and i understand that is because the driver is too old... or maybe I'm wrong
So is there any possibility to extract the openGL files from the old driver to implement them in the new one ?
I have noticed another thing that dxdiag64-bit is reporting : Approx Total Memory : 173 MB which is wrong (with the latest driver)
with the old driver ati_catalyst_10.7beta dxdiag-64bit is reporting more than 2GB's.

All have been said i think is all about the OpenGL files or my laptop GPU is failing to load new drivers ?
I have to say that before 1 month ago the GPU was working properly with latest driver...

Here is the report of dxdiag64
https://ufile.io/dbbd1

Difference between display files :
https://ufile.io/f595e

opengl check :
https://ufile.io/a1156
https://ufile.io/605eb

Another issue :
https://ufile.io/4c7a4

P.S: If here is not the right forum where should I be, please guide me where to go to ask. Thank you.

mamannon
01-14-2017, 11:31 AM
So is there any possibility to extract the openGL files from the old driver to implement them in the new one ?

No way. You cannot mix and matc executable files between different driver versions. That may work, but that's like a win in a lottery.

The problem you describe indicates a bug in a game. There may be a bug in AMD driver as well. It is possible that the game works perfectly in another computer, especially with NVIDIA graphics card. My experience as a graphics developer is that it is easier to get an OpenGL program working correctly in a NVIDIA card than an AMD card.

kvexino
01-14-2017, 12:36 PM
No way. You cannot mix and matc executable files between different driver versions. That may work, but that's like a win in a lottery.

The problem you describe indicates a bug in a game. There may be a bug in AMD driver as well. It is possible that the game works perfectly in another computer, especially with NVIDIA graphics card. My experience as a graphics developer is that it is easier to get an OpenGL program working correctly in a NVIDIA card than an AMD card.

I think i have found the bug but i don't know how to solve it.
dxdiag64 bit with ati catalyst 15.7.1 driver sees no video drivers installed

dxdiag64 bit with ati catalyst 10.7 beta driver sees all drivers.

Here is the proof

https://s29.postimg.org/lv63uhwub/diference_old_new_dxdiag.jpg (https://postimg.org/image/lv63uhwub/)


The game is Lineage 2 Helios the game was working before. There is something that is not letting ati catalyst 15.7.1 to install it properly as you can see in dxdiag64 report

mamannon
01-14-2017, 01:30 PM
I think i have found the bug but i don't know how to solve it.

You cannot solve it. To fix a bug you need at least a compiler and the source code of that game you could debug the game and rewrite the failing part of the source code. Looking at which files are involved and which are not and trying to get all files working, is nonsense which does't solve your problem.

kvexino
01-14-2017, 02:10 PM
You cannot solve it. To fix a bug you need at least a compiler and the source code of that game you could debug the game and rewrite the failing part of the source code. Looking at which files are involved and which are not and trying to get all files working, is nonsense which does't solve your problem.

It's not about the game is about the ati driver, the game is working properly


the game is working on ati catalyst driver 10.7beta (image shaking)
the game is NOT working on ati catalyst driver 15.7.1