PDA

View Full Version : Vulkan driver upgrade not working



PadMad
08-24-2016, 10:55 AM
Ubuntu 16.04
64 bit
GeForce GT 710 (has Vulkan support!)
-------------------

Hey,

Not sure, if this is the right forum... Vulkan is quite new, and there aren't really opportunities to ask questions, but I'll try. I tried to install the vulkan driver upgrade from this page: https://developer.nvidia.com/vulkan-driver
I chose the 64 bit version, logged out, closed x-session, made it executable, run it and recieved the following error log...



nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Aug 24 12:49:41 2016
installer version: 367.27

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
./nvidia-installer

Unable to load: nvidia-installer ncurses v6 user interface

Using: nvidia-installer ncurses user interface
-> Detected 8 CPUs online; setting concurrency level to 8.
-> License accepted.
-> Installing NVIDIA driver version 367.27.
-> Running distribution scripts
executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> The distribution-provided pre-install script failed! Are you sure you want to continue? (Answer: Continue installation)
ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf. Please be sure you have rebooted your system since these files were written. If you have rebooted, then Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X configuration file. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.


I'm following the tutorial on http://www.vulkan-tutorial.com . example doesn't work, 'cause the vulkan driver doesn't work. so why is that? I followed the simple steps... it makes no sense...

Thanks for any help in advance

Dark Photon
08-24-2016, 04:24 PM
I tried to install the vulkan driver upgrade from this page: https://developer.nvidia.com/vulkan-driver
I chose the 64 bit version, logged out, closed x-session, made it executable, run it and recieved the following error log...



...
ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf. Please be sure you have rebooted your system since these files were written. If you have rebooted, then Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X configuration file. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.



Did you reboot as well? See the error message above.

For context, Nouveau (https://nouveau.freedesktop.org/wiki/) is an open source driver for NVidia GPUs on Linux, typically enabled by default on Linux distros. It is alternative to using the NVidia propriatary GPU driver (which supports OpenGL and Vulkan). It is comprised of a Linux kernel module and an X server driver. NVidia's driver has a kernel module as well.

In order for the NVidia driver to work, you have to make sure that Nouveau is unplugged from your system so it doesn't "take over" your GPU on boot.

Find a Ubuntu guide on disabling the Nouveau driver (search for "blacklist nouveau ubuntu"). Here's one:

* http://www.allaboutlinux.eu/remove-nouveau-and-install-nvidia-driver-in-ubuntu-15-04/

or for Linux-general instructions, search down for "blacklist nouveau" in the NVidia driver README.txt (it installs it here):

* /usr/share/doc/NVIDIA_GLX-1.0/README.txt

Briefly, the main thing is to make sure that 1) the "nouveau" kernel module isn't loaded so NVidia's kernel module can load when you fire up X and 2) X is set to use the "nvidia" driver instead of the "nouveau" driver to talk to your GPU. IIRC, the NVidia driver installer tries to take care of both of these for you so you don't have to do much if anything besides run their driver installer.

PadMad
08-27-2016, 02:32 AM
Hey,

Thanks for your reply.
Tried every step from the link you sent. I even blacklisted nouveau in /etc/modprobe.d/blacklist.conf
Still... when I try to run nvidia.run file it says that nouveau is enabled. I read on the internet, that the steps are nearly the same on every website as mentioned on your website link.
Why is that? Still... it makes no sense.



nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Aug 27 10:27:02 2016
installer version: 367.27

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
./nvidia-installer

Unable to load: nvidia-installer ncurses v6 user interface

Using: nvidia-installer ncurses user interface
-> Detected 8 CPUs online; setting concurrency level to 8.
-> License accepted.
-> Installing NVIDIA driver version 367.27.
-> Running distribution scripts
executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> The distribution-provided pre-install script failed! Are you sure you want to continue? (Answer: Continue installation)
ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf. Please be sure you have rebooted your system since these files were written. If you have rebooted, then Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X configuration file. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.


it says I have to reboot. That I did and it would lead to a blackscreen then. every time I would try to reboot, there is a blackscreen.
that would lead to reinstall ubuntu. cause I dont have any control at all. no terminal appearing!

I am patient. But I m getting tired of getting errors nobody else seems to get.

Dark Photon
08-27-2016, 08:42 PM
I don't run Ubuntu, , but here are a couple ideas to try.

Sometimes distros will have an NVidia driver package available through the distro's package manager. Look for it. It may automate the "disable nouveau and install/enable nvidia driver" work needed for your distro. Alternatively...

Find out how to boot into a "text-only, no GUI" runlevel on Ubuntu. In other distros, you just boot with a "3" as an added kernel argument. If not 3, try 1. What you'd like to do is boot the system without X and the nouveau driver getting a chance to load up. Once you figure this out, run "lsmod | grep -i nouveau" to make sure that there is no Nouveau kernel module loaded. Now run the NVidia driver installer script and see if you fare better.

You also might search for and if necessary post a question about your problem on Ubuntu forums. This has to be something others have hit before on Ubuntu. There's doubtless a comprehensive guide or method available for Ubuntu to switch from running nouveau to running the NVidia driver.

Another thought: See if your distro installer tool has an option available in the installer to use the NVidia driver instead of nouveau.

PadMad
08-29-2016, 08:45 AM
Thanks for your help. It works now.
I found out, that I just can choose a graphics driver in the ubuntus system settings. I was able to choose the relevant driver there.

system -> software & updates -> additional drivers

thanks!

mauthietke
09-22-2016, 10:27 PM
I not running ubuntu I do not know :doh:

cali9x
10-02-2016, 01:46 AM
Find out how to boot into a "text-only, no GUI" runlevel on Ubuntu. In other distros, you just boot with a "3" as an added kernel argument. If not 3, try 1. What you'd like to do is boot the system without X and the nouveau driver getting a chance to load up. Once you figure this out, run "lsmod | grep -i nouveau" to make sure that there is no Nouveau kernel module loaded. Now run the NVidia driver installer script and see if you fare better.