PDA

View Full Version : Plz help!?!?!?!



PokePickleYT
08-12-2016, 01:30 PM
I can't play a game on steam I want to play because whenever I run it a message pops up saying "This game requires OpenGL 3.3 or higher,You computer has 2.1" And the game close!Can anyone tell me how to fix this / update OpenGL?? :(

john_connor
08-12-2016, 04:40 PM
update your graphics card driver
if you graphics card supports openGL 3.3, then updating the driver will fix it

dagreen
08-23-2016, 10:36 AM
I've had the same problem and I needed to upload the new version :/

vernon750
08-26-2016, 07:21 AM
When you want to play high end games then you need to have high end graphics card.I am lover of games i bought high end pc especially for playing games.:D