PDA

View Full Version : OpenGL GLSL 3.30 in Ubuntu 14.10 mesa 10.1.3



abijosh
01-09-2016, 07:13 PM
when I try to compile a glsl shader with OpenGL in Ubuntu I get the following error: GLSL 3.00 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, 1.50, 3.30, 1.00 ES, and 3.00 ES

But when I do a "glxinfo | grep OpenGL" it says:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.9
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.5.9
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.5.9
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:


I've no clue what I'm missing here. I'm using glfw3 library and in my shader code I've specified #version 300

GClements
01-09-2016, 07:57 PM
when I try to compile a glsl shader with OpenGL in Ubuntu I get the following error: GLSL 3.00 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, 1.50, 3.30, 1.00 ES, and 3.00 ES



in my shader code I've specified #version 300

Have you tried #version 330 ?

abijosh
01-09-2016, 09:59 PM
Have you tried #version 330 ?

Its working when I specified #version 330