PDA

View Full Version : [Linux] issues with intel graphic cards



hurukan
11-20-2015, 05:36 AM
Greetings !!

I got some troubles with two computers equiped with intel graphics chipsets (laptops).

I use opengl with shaders and fragments in some applications and when using my laptops (to demonstrate to my students) I got errors when compiling the shaders/fragments.

I tried to find the correct drivers for the distribution (opensuse 13.2) but it seems there is no support for this distribution.

Errors given:

glsl 1.50 is not supported: supported versions are 1.10 1.20 1.30 1.00 ES 3.00 ES


I know that Uniform are not supported before 4.3 how can I update the GLSL and opengl version ?

mhagain
11-20-2015, 08:01 AM
GLSL and OpenGL versions are dependent on your hardware and drivers.

hurukan
11-21-2015, 04:03 AM
I was thinking it was a standard and the manufacturers were developing 'extensions' to highlight the superiority of their conceptions.

I will go back to opensuse forums to obtain something.

Thanks.

mhagain
11-21-2015, 07:08 AM
OpenGL is a standard, yes, but it's a standard with multiple versions, each incrementally built on the previous. It's also not software that you can just upgrade.