PDA

View Full Version : Variables



Sidney
05-16-2015, 11:29 AM
Running Win7 Pro on Laptop, running Win7 Ultimate on desktop, identical MFC workspace runs fine on laptop but when transferring to desktop, linker gets unresolved external symbol, _main, not sure how to resolve this one.

Alfonse Reinheart
05-16-2015, 01:04 PM
Didn't we talk about you making new threads for the same problem before? (https://www.opengl.org/discussion_boards/showthread.php/186248-Includes) Also, asking the question multiple times doesn't suddenly make a non-OpenGL question into an OpenGL question. It's still a "building C++ applications" question.

Sidney
05-17-2015, 09:29 AM
Alfonse: My question has little to do with building C++ applications, I know that I am not proficient in C++ and MFC, I program extensively in Fortran and scientific applications and only want to use the OpenGL system with C++ to display the results of my Fortran, mathematical calculations, this has worked fine in the past on my laptop computer. I am only confused about why the same workspace utilized in the same Visual Studio application would produce two different results on two different computers, one giving an error of a missing variable "main" on the desktop computer and one that runs perfectly on the laptop computer. Any ideas on a solution to this problem would be much appreciated.

Sidney
05-17-2015, 09:41 AM
Alfonse: Figured it out, I started a new project in MFC, created it as a windows32 application, opened my "OpenGL" C++ file, created a new workspace, compiled and linked, all worked great. the compile setting were created as a "Windows" application not a "console" application, this was the problem all along. Apparently a windows application was created originally on the laptop and the default on the desktop was a console app. Thanks for the help

hidefromkgb
05-17-2015, 10:41 AM
Sidney, this is what GClements (https://www.opengl.org/discussion_boards/showthread.php/186248-Includes?p=1266427&viewfull=1#post1266427) already told you, isn`t it?

[offtopic]
Alfonse Reinheart, the third link in your forum signature leads nowhere. To be precise, it expired two months ago.
This is the last working snapshot (http://web.archive.org/web/20150311211412/http://www.arcsynthesis.org/gltut/) from the WaybackMachine. Seems to be complete.
I sent you a similar PM some time ago, but apparently it wasn`t delivered.