PDA

View Full Version : Opengl calls not working



Lucky8
01-13-2015, 12:38 AM
I would like to paste a log from GLDIRECT, (I use it to reasearch a little about issue I was having) and I found this:

GLD: (SYS) -> Logging Started
GLD: (SYS) Driver : SciTech GLDirect 5.0
GLD: (SYS) Executable : D:\PandoraMU_S8E3_FULL\game.des
GLD: (SYS) DirectDraw device: Primary
GLD: (SYS) Direct3D driver : Direct3D Hardware Renderer
GLD: (SYS) Rendering type : Direct3D HW
GLD: (SYS) Multithreaded : Disabled
GLD: (SYS) Display resources: Instanced
GLD: (SYS) Buffer resources : Instanced
GLD: (SYS) Vertex Shader : 3.0
GLD: (SYS) Pixel Shader : 3.0
GLD: (SYS) DirectX Version : 9.0 or above
GLD: (INF)
GLD: (INF) Pixel Formats:
GLD: (INF) visual x bf lv rg d st r g b a ax dp st accum buffs ms
GLD: (INF) id dep cl sp sz l ci b ro sz sz sz sz bf th cl r g b a ns b
GLD: (INF) -----------------------------------------------------------------
GLD: (INF) 0x01 32 wn . 32 . r . . 8 8 8 . . 16 . . . . . . .
GLD: (INF) 0x02 32 wn . 32 . r . . 8 8 8 . . 32 . . . . . . .
GLD: (INF) 0x03 32 wn . 32 . r . . 8 8 8 . . 32 8 . . . . . .
GLD: (INF) 0x04 32 wn . 32 . r y . 8 8 8 . . 16 . . . . . . .
GLD: (INF) 0x05 32 wn . 32 . r y . 8 8 8 . . 32 . . . . . . .
GLD: (INF) 0x06 32 wn . 32 . r y . 8 8 8 . . 32 8 . . . . . .
GLD: (INF) -----------------------------------------------------------------
GLD: (INF)
GLD: (SYS) ChoosePixelFormat:
GLD: (INF) Input pixel format for ChoosePixelFormat:
GLD: (INF) visual x bf lv rg d st r g b a ax dp st accum buffs ms
GLD: (INF) id dep cl sp sz l ci b ro sz sz sz sz bf th cl r g b a ns b
GLD: (INF) -----------------------------------------------------------------
GLD: (INF) . 16 wn . 16 . r y . . . . . . 16 8 . . . . . .
GLD: (INF) -----------------------------------------------------------------
GLD: (INF)
GLD: (SYS) Pixel Format 6 chosen as best match
GLD: (SYS) SetPixelFormat: PixelFormat 6 has been set
GLD: (SYS) gldCreateContext for HDC=A011BF4, ThreadId=93C
GLD: (SYS) gldCreateContextBuffers for HDC=A011BF4
GLD: (INF) Input window 330572: w=800, h=600
GLD: (INF) OS: Win2000/XP
GLD: (SYS) [DDI Driver Level : 900]
GLD: (INF) [Driver Description: AMD Radeon HD 6670]
GLD: (INF) [Driver file: aticfx32.dll 8.17.10.1315]
GLD: (INF) [VendorId: 0x1002, DeviceId: 0x6758, SubSysId: 0x3E01043, Revision: 0x0]
GLD: (INF) Can Scissor: Yes
GLD: (INF) Window: w=800, h=600 (windowed)
GLD: (INF) HW TnL: Enabled
GLD: (SYS) gldCreateContext succeeded for HGLRC=1
GLD: (INF) Calling app has been activated
GLD: (INF) GetProcAddress: glBlendEquation (Failed)
GLD: (INF) GetProcAddress: glBlendFuncSeparate (Failed)
GLD: (INF) GetProcAddress: glDrawRangeElements (Failed)
GLD: (INF) GetProcAddress: glMultiTexCoord4fv (Failed)
GLD: (INF) GetProcAddress: glActiveTexture (Failed)
GLD: (INF) GetProcAddress: glClientActiveTexture (Failed)
GLD: (INF) GetProcAddress: glEnableVertexAttribArrayARB (Failed)
GLD: (INF) GetProcAddress: glDisableVertexAttribArrayARB (Failed)
GLD: (INF) GetProcAddress: glVertexAttribPointerARB (Failed)
GLD: (INF) GetProcAddress: glVertexAttrib4fARB (Failed)
GLD: (INF) GetProcAddress: glDeleteObjectARB (Failed)
GLD: (INF) GetProcAddress: glCreateShaderObjectARB (Failed)
GLD: (INF) GetProcAddress: glShaderSourceARB (Failed)
GLD: (INF) GetProcAddress: glCompileShaderARB (Failed)
GLD: (INF) GetProcAddress: glCreateProgramObjectARB (Failed)
GLD: (INF) GetProcAddress: glAttachObjectARB (Failed)
GLD: (INF) GetProcAddress: glLinkProgramARB (Failed)
GLD: (INF) GetProcAddress: glUseProgramObjectARB (Failed)
GLD: (INF) GetProcAddress: glGetInfoLogARB (Failed)
GLD: (INF) GetProcAddress: glGetUniformLocationARB (Failed)
GLD: (INF) GetProcAddress: glUniform4fARB (Failed)
GLD: (INF) GetProcAddress: glUniform1iARB (Failed)
GLD: (INF) GetProcAddress: glGetObjectParameterivARB (Failed)
GLD: (INF) GetProcAddress: glProgramStringARB (Failed)
GLD: (INF) GetProcAddress: glBindProgramARB (Failed)
GLD: (INF) GetProcAddress: glProgramLocalParameter4dARB (Failed)
GLD: (INF) GetProcAddress: glGenProgramsARB (Failed)
GLD: (INF) GetProcAddress: glDeleteProgramsARB (Failed)
GLD: (INF) GetProcAddress: glGenBuffersARB (Failed)
GLD: (INF) GetProcAddress: glDeleteBuffersARB (Failed)
GLD: (INF) GetProcAddress: glBindBufferARB (Failed)
GLD: (INF) GetProcAddress: glBufferDataARB (Failed)
GLD: (INF) GetProcAddress: glCompressedTexImage2D (Failed)
GLD: (INF) Calling app has been de-activated
GLD: (INF) Calling app has been activated
GLD: (INF) Calling app has been de-activated
GLD: (SYS) gldDeleteContext: Deleting context HGLRC=1, ThreadId=93C
GLD: (SYS) shutting down after WM_DESTROY detected for main HWND=330572
GLD: (SYS) <- Logging Ended



But it still works just very slow because CPU takes the calls. Why? I have most recent GPU driver. I always do and this keep coming.

It doesn't work in XP, Vista, W7. W8, W10 :(

GClements
01-13-2015, 10:52 PM
GLDirect hasn't been updated in years, and doesn't support the functions which are marked as (Failed) in the log.

Lucky8
01-13-2015, 11:13 PM
GLDirect hasn't been updated in years, and doesn't support the functions which are marked as (Failed) in the log.

Ok thanks for your answer.
Still my card doesn't seems to work with old Opengl application. Of course I first tested without GLDirect.
Should I throw away my graphic card or delete the game?

GClements
01-14-2015, 05:41 PM
Should I throw away my graphic card or delete the game?
First, I'd try to find out why it doesn't work.

Does the game provide any details of the OpenGL version? If it doesn't, use a utility such as GLview to determine the available OpenGL version. If it's reporting 1.2, you only have Windows' software fallback, and need to re-install the drivers (in some cases, you may need to use a utility such as Driver Sweeper to fully remove the existing driver first).

If it's reporting a modern version but the game won't run, search for information (and possible workarounds) on that specific game.