PDA

View Full Version : Installed new GPU & OpenGL is now only version 1.1



dmcneice
01-02-2015, 09:08 AM
A little help, please? I need to update OpenGL from 1.1 to 3 or better. I am basically stuck similar to this thread (https://www.opengl.org/discussion_boards/showthread.php/175563-Installed-new-GPU-OpenGL-is-now-only-version-1-1) which is closed and has no resolution. Also, there is an image posted but it is no accessible any longer. My son purchased a new graphics card. The card requires OpenGL 2.0 or better. His pc has OpenGL1.1 on it.
The the device driver is installed properly
In "Device Manager" the display adapter has no issues and states that the driver for the Radeon R9 270X is working properly.

I have downloaded the current drivers from the AMD site. That did not change the version of OpenGL. I tried uninstalling the old drivers, old NVidia Drivers, Restarting the pc. Clean install of drivers, etc. Nothing seems to let me update the OpenGL.

Some games work but the frame rate is very slow. Some games just crash immediately.

https://www.opengl.org/discussion_boards/showthread.php/175563-Installed-new-GPU-OpenGL-is-now-only-version-1-1

Alfonse Reinheart
01-02-2015, 10:59 AM
A new graphics card was installed. Was it in fact a Radeon R9 270? If so, was the old one an AMD card? And most important of all, did you uninstall the previous drivers?