PDA

View Full Version : Installing OpenGL



jsmith613
06-25-2014, 03:29 PM
I am trying to build a project with Geant4 but I recieved this message



#Use this open statement to create OpenGL view:
/vis/open OGL 600x600-0+0
parameter value is not listed in the candidate List.
***** Illegal parameter (0) </vis/open OGL 600x600-0+0> *****
***** Batch is interrupted!! *****


My yum isn't working so I can't "yum install Open OGL" [i don't actually know if that works]....how do I install OpenGL to /vis

thanks

mhagain
06-25-2014, 04:54 PM
You don't install OpenGL because OpenGL is not software.

Instead you must install the drivers for your video card.

jsmith613
06-26-2014, 02:00 AM
You don't install OpenGL because OpenGL is not software.

Instead you must install the drivers for your video card.

how do I get the drivers then and where do I put them? I specifically need OpenGL?
thanks

Agent D
06-26-2014, 02:27 AM
You need to install the apropriate drivers for your graphics card. You mentioned yum, so I'm assuming you are using a GNU/Linux distribution.

If you have an Intel card, install "mesa"

If you have an ATI card, you can install the proprietary driver from their website (AFAIK they have a shell script for installation) or install "mesa" with the "radeonhd" drivers.

If you have an NVIDIA card, you can install the proprietary driver from their website (they have a shell script for installation) or install "mesa" with the "nouveau" drivers.

jsmith613
06-26-2014, 02:35 AM
You need to install the apropriate drivers for your graphics card. You mentioned yum, so I'm assuming you are using a GNU/Linux distribution.

If you have an Intel card, install "mesa"

If you have an ATI card, you can install the proprietary driver from their website (AFAIK they have a shell script for installation) or install "mesa" with the "radeonhd" drivers.

If you have an NVIDIA card, you can install the proprietary driver from their website (they have a shell script for installation) or install "mesa" with the "nouveau" drivers.

ok so I am to use mesa. thanks.
i seem to be having problems though with my yum...it stopped working some time last week....this is the message I get



[root@localhost bob]# yum install mesa
Loaded plugins: changelog, kernel-module, protectbase, refresh-packagekit,
: security, tsflags, versionlock
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-6.5&arch=x86_64 error was
14: PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.rpmfusion.org'"
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rpmfusion-free. Please verify its path and try again
[root@localhost bob]# yum install mesa
Loaded plugins: changelog, kernel-module, protectbase, refresh-packagekit,
: security, tsflags, versionlock
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rpmfusion-free. Please verify its path and try again