PDA

View Full Version : Does ARB_ES2_compatibility allow the use of ES 2.0 shaders as well?



digitalsynapses
06-11-2014, 06:53 PM
I currently have a mostly unified render path based around ES 2.0, with some platform specific pieces for desktop. I would really like to get rid of those platform specific pieces. That being said, will using ARB_ES2_compatibility allow me to use native ES 2.0 shaders within the desktop environment without modification? Thanks in advance.

arekkusu
06-11-2014, 08:44 PM
You'll need to prepend "#version 100".

...and there's no provision for any ES-specific #extensions...