PDA

View Full Version : Hello Triangle doesn't run



Renger
05-29-2014, 10:17 AM
Hello,

I am trying to do the first tutorial from the online book 'Learning Modern 3D Graphics Programming' of Jason L. McKesson.

I figured out how to build the SDK libraries, and now I try to build the tutorial itself. Everything seems te be fine, but upon running this message appears in my .exe screen: 'freeglut <c:\OpenGL\Tut 01 Hello Triangle\.\Tut 01 Main.exe>: Unable to create OpenGL 3.3 context <flags 0, profile 1>'

No errors, only this.

I read it might have something to do with my videocard.

I am using an acer 5740, OS: Windows 7, graphics card: ATI Mobility Radeon 5xxx

If more information is needed, ask for it, and I will try to provide it :)

Anyone?

Aleksandar
05-29-2014, 02:27 PM
Mobility Radeon HD 5xxx should be OpenGL 3.3 compatible. Try to install some newer Catalyst drivers.
Before reinstalling drivers, you could check the current version with OpenGL Extension Viewer (http://www.realtech-vr.com/glview/download.php).

rodrigoloc
06-01-2014, 09:09 PM
Have you got example's code? That error code doesn't look like a freeglut error. Is freeglut's .dll in your current working directory?