PDA

View Full Version : glConvolution nightmare



giumas
11-29-2013, 11:31 PM
Dear friends,

I am having a very bad time in dealing with glConvolutionFilter2D on Ubuntu 12.04 lts (vmWare player). I have tried to make it working with both the apt-get mesa driver and the last available version. It continues to provide the pretty error INVALID_ENUM.. I have also tempted to use the old GL_EXT_convolution. Unluckily I need that function since it is part of a big project.
I got the same INVALID_ENUM also using OSMesa.. any idea? what else can I try? help me, guys!!

mhagain
11-30-2013, 02:55 AM
What graphics card have you? This is a more important factor than the OS.

giumas
11-30-2013, 08:26 AM
Sorry for the missing information.. NVDIA quadro 600
I have also forgot to say that the same program works fine on the same computer (without vmWare player) that runs Win7 Pro 64 bit

Digging on the web I found this thread: lists.freedesktop.org/archives/mesa-dev/2010-September/003099.html
I am wondering if they remove the support for convolution in the Mesa drivers from a given release... since in the past I run the code without troubles on vmWare with Ubuntu!