PDA

View Full Version : Linker issue



sanyibacsi
08-27-2013, 04:48 PM
Hello There,

I try to compile a small application and I get a number of errors like:


/usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to `xcb_glx_set_client_info_arb'
/usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to `xcb_glx_create_context_attribs_arb_checked'
/usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to `xcb_glx_set_client_info_2arb'
/usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to `_XGetRequest'


I have CentOS 6.0 running gstreamer 0.10.29 and mesaGL 1.2.0. And I have no idea how to fix this even after quite a few years of coding (mainly on Windows anyway).

Thanks :)

GClements
08-28-2013, 04:18 AM
I try to compile a small application and I get a number of errors like:


/usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to `xcb_glx_set_client_info_arb'

These are all defined in libxcb-glx.so. That library should be a dependency of libGL.so, and get linked automatically. You can try adding -lxcb-glx to the linker flags as a workaround, but the fact that this doesn't work out of the box suggests that there are other factors involved. Did you get any other error messages prior to those? Did you try to install OpenGL (or any related components) other than using the normal package installation mechanism?