PDA

View Full Version : Error at rendering with textures



Marc Colomé
08-16-2013, 01:13 PM
I'm using the code of this tutorial (see "download source" code inside of the page for the files)

h t t p : / / w w w . videotutorialsrock . com / opengl _ tutorial / textures / video . p h p

(link without spaces)

I get this error in a dialog:

Debug error!

R6010

- abort() has been called

(please retry to debug the aplication)

And in a command:

Assertion failed: !input.fail<> || !"could not find file", file c:\documents and settings\...


What I'm doing wrong?

Marc Colomé
08-17-2013, 05:47 AM
Anyone knows?

carsten neumann
08-17-2013, 02:15 PM
Do you have the file it is looking for in the location it is looking for it?

Marc Colomé
08-18-2013, 06:29 AM
i have this bit of code:

Image* image = loadBMP("C:\vtr.bmp");

and the vtr.bmp in the c:\

carsten neumann
08-18-2013, 10:49 AM
In C/C++ string literals "\" is used as escape character, normally used to introduce non-printing/control characters, like "\n" for newline, "\t" for tab, etc. To get a literal \ you have to write "\\", i.e. two backslash characters.
I've looked at the original code, it just uses a relative path to the .bmp file. To make that work you may have to adjust the working directory settings for your project (it looks to me like you are using Visual Studio; it is somewhere in the project settings - sorry don't have VS at hand for more precise instructions).

Marc Colomé
08-18-2013, 03:10 PM
In C/C++ string literals "\" is used as escape character, normally used to introduce non-printing/control characters, like "\n" for newline, "\t" for tab, etc. To get a literal \ you have to write "\\", i.e. two backslash characters.
I've looked at the original code, it just uses a relative path to the .bmp file. To make that work you may have to adjust the working directory settings for your project (it looks to me like you are using Visual Studio; it is somewhere in the project settings - sorry don't have VS at hand for more precise instructions).

Just puting \\ worked fine! THANK YOU SO MUCH!!