PDA

View Full Version : first opengl program



Halozination
07-24-2013, 09:54 AM
hi,
I am trying to learn opengl by following a tutorial. The tutorial uses external libraries (glfw, glew, glm,...) and I want to get them working from an empty project (I have not used external libraries before).
I am using windows and visual studio 2010 and downloaded the 3 libraries from their websites and extracted them to my project folder. glew and glfw both have include and lib folders which I added in the properties. glm does not have those folders so I am not sure what to do.

However still nothing is working I get Link 2019 and Link1120 errors saying that there are a lot of things undissolved when I call functions from glfw or glew. In the tutorial samples there are some entries in the linker properties under additional dependencies

kernel32.lib
user32.lib
gdi32.lib
winspool.lib
shell32.lib
ole32.lib
oleaut32.lib
uuid.lib
comdlg32.lib
advapi32.lib
glu32.lib
opengl32.lib
external\Debug\GLFW_276.lib
external\Debug\GLEW_190.lib

But I don't think I extracted those files from the downloads. I could use the files from the samples I suppose but how do I get the libraries running without them?
Help please..

tonyo_au
07-24-2013, 06:48 PM
glm is a template library and so has no lib. If you are getting link errors check you have the correct path name for the libraries in the "Additional Library Directories" under linker\General or put the full path name in the library name in Linker\Input\Additional Dependencies