PDA

View Full Version : help building openGL sdk 0_4_4 (not finding premake.lua)



OpenGLNewbie3344
05-08-2013, 06:36 PM
I realize this must of been asked a million million times but I can't find a good answer to this problem I'm having. Basically my problem is this:



but as you'll see in the next image, premake4.lua IS in the same directory as premake4.exe so I don't know what to do. I've noticed SciTE returns errors in the lua scripts.






>lua -e "io.stdout:setvbuf 'no'" "premake4.lua"
lua: premake4.lua:1: attempt to call global 'solution' (a nil value)
stack traceback:
premake4.lua:1: in main chunk
[C]: ?
>Exit code: 1



and in links.lua



>lua -e "io.stdout:setvbuf 'no'" "links.lua"
lua: links.lua:1: attempt to call field 'getcwd' (a nil value)
stack traceback:
links.lua:1: in main chunk
[C]: ?
>Exit code: 1


if this wont work or no one can help me, is there anywhere I could just get the binaries? this is driving me crazy

PS. i can't post any links since i'm new.........bummer

Alfonse Reinheart
05-08-2013, 08:15 PM
lua -e "io.stdout:setvbuf 'no'" "premake4.lua"

Why are you doing that? The build documentation (http://glsdk.sourceforge.net/docs/html/pg_build.html) doesn't say to download, install, and use Lua. It says to download, install, and run Premake4. Your command line should be:


premake4 ...

Where "..." is whatever build tool you're using to compile these. The instructions even have examples of command lines to use.

OpenGLNewbie3344
05-08-2013, 08:50 PM
aside the fact that I've had LUA installed before, it still doesn't work. premake4.exe cannot find premake4.lua but the file(s) are in the same folder....DANG i wish I could show a picture.

Alfonse Reinheart
05-08-2013, 09:40 PM
premake4.exe cannot find premake4.lua but the file(s) are in the same folder

What directory are you in when you run premake4?

OpenGLNewbie3344
05-08-2013, 10:27 PM
What directory are you in when you run premake4?


C:\Users\Rosario\Downloads\glsdk_0.4.4\glsdk_0.4.4

i'd show you a picture but since I'm new, I can't post images.........if you give me your e-mail I can send them that way.