PDA

View Full Version : Trouble with OpenGL version



YurySerdyuk
04-22-2013, 12:56 PM
Hi !

I have machine under CentOS 5.6 with Nvidia Tesla C1060 GPU:

>01:00.0 3D controller [0302]: nVidia Corporation GT200 [Tesla C1060] [10de:05e7] (rev a1)
> Subsystem: nVidia Corporation Device [10de:066a]
> Kernel driver in use: nvidia
> Kernel modules: nvidiafb, nvidia

I have installed 310.32 driver for Tesla:

> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (310.32):

I expect, at least, 2.1 version of OpenGL for this machine, but glxinfo gives me:

OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 1.4 (2.1 Mesa 7.11-devel)

What is wrong in my installation?

In particular, I have another similar machine without GPU Tesla and only
with ATI controller:

0a:01.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)

And the OpenGL version is the same on it:

OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 1.4 (2.1 Mesa 7.11-devel)

How to provide OpenGL version >= 2.0 on the first machine?

Thanks.