PDA

View Full Version : libGLEW.so for OpenGL 3.3



debonair
04-09-2013, 01:14 AM
Does anyone have patched glew.so which will work for GL 3.2 ? As getting extensions using glGetstring(GL_EXTENSIONS) fails on core 3.2, it gives segfault.

Alfonse Reinheart
04-09-2013, 03:20 AM
It shouldn't "gives segfault". It should give a GL_INVALID_ENUM OpenGL error. Granted, the attempt the use the NULL pointer it returns will likely give a segfault.

But anyway, you can use the usual workaround for the problem. (http://www.opengl.org/wiki/OpenGL_Loading_Library#GLEW). Or you could use any of the other OpenGL loaders described on that page. GLEW is hardly the only game in down as far as loading OpenGL functions is concerned.

carsten neumann
04-09-2013, 10:19 AM
There's also the patch attached to glew's bug report #174 (http://sourceforge.net/p/glew/bugs/174/) to attempt to fix this - it probably wouldn't hurt if folks gave it some extra testing ;)

Alfonse Reinheart
04-10-2013, 12:35 AM
You'd think, considering the prominence of GLEW as a tool in the community and how broken this is that people are frequently asking about this problem, that the GLEW maintainer would push out a release of the patched version ASAP. I mean, he can put together a new GLEW release whenever a new batch of extensions show up in less than a day. But making the tool actually work seems to be less important somehow.

menzel
04-10-2013, 02:36 AM
You'd think, considering the prominence of GLEW as a tool in the community and how broken this is that people are frequently asking about this problem, that the GLEW maintainer would push out a release of the patched version ASAP. I mean, he can put together a new GLEW release whenever a new batch of extensions show up in less than a day. But making the tool actually work seems to be less important somehow.

Tell me about it :-(
GLEW for pure core profiles (as *needed* for OpenGL 3.2 on Macs) is broken for years...
I switched to glLoadGen because of that on all platforms (https://bitbucket.org/alfonse/glloadgen/wiki/Home) :-)

debonair
04-11-2013, 01:42 AM
There's also the patch attached to glew's bug report #174 (http://sourceforge.net/p/glew/bugs/174/) to attempt to fix this - it probably wouldn't hurt if folks gave it some extra testing ;)

Thanks, it works with patch.. :)

debonair
04-11-2013, 01:44 AM
Tell me about it :-(
GLEW for pure core profiles (as *needed* for OpenGL 3.2 on Macs) is broken for years...
I switched to glLoadGen because of that on all platforms (https://bitbucket.org/alfonse/glloadgen/wiki/Home) :-)

dude, check out the link given in 3rd post in this discussion, apply that patch and it loads the pointers perfectly..

menzel
04-11-2013, 03:19 AM
dude, check out the link given in 3rd post in this discussion, apply that patch and it loads the pointers perfectly..

Sure there is a patch and I can also fix the problem on my own (and I have). But not including such a simple fix that breaks the whole lib for one OS for many, many month does not increase my trust in GLEW... I'll stick with the (for me) better working and more feature rich alternatives :-)