PDA

View Full Version : glfwOpenWindow returns null



compmaster
03-09-2013, 10:32 PM
Hello OpenGL Forums! I am a beginner trying to get into OpenGL. I am trying to an the first OpenGL tutorial the opengl-tutorial.org website(opengl-tutorial.org/beginners-tutorials/tutorial-1-opening-a-window/), however the example posted doesn't seem to work for me.

I am able to compile the program fine without any errors and/or warnings, but when run, the program errors saying that it Failed to open the GLFW window. If you follow the code on the page, this message only appears when glfwOpenWindow fails. I'm not sure what is going wrong.

I have a sneaking suspicion that is has something to due the the current environment that I am working in... but I am unsure how to diagnose the issue. I am running on a base install of Arch Linux-3.7.9-2 on an Intel Atom CPU D2700 with a nVidia GT 520 graphics card. The only things installed on the system are the base and base-devel packages, Xorg, and a few other minor and unrelated packages. Since I am running this strictly on a command line, I run the following command to test the compiled program:

$ xinit ./tutorial01_first_window
From my understanding, this will start up the X Server and then run the compiled program on that instance of X.

I've seen the previous post on this forum about glfwOpenWindow failing(opengl.org/discussion_boards/showthread.php/176821-glfwOpenWindow%28%29-is-failing), but those solutions do not seem to solve my current problem. Any help to diagnose this problem would be helpful.

Thanks!