PDA

View Full Version : OpenGL on web server



elisokal
02-26-2013, 05:19 AM
I am looking for advice. A web application I developed depends on basic OpenGL extensions. It works well enough on my modest Windows 7 i5 Acer PC using only the on-board Intel HD Graphics. But when deployed at my web host on Windows Server 2008 or 12, the count of OpenGL extensions drops from 94 to 3 and my functionality mostly disappears. It appears impossible to enable OpenGL extensions on these Windows Server OS's. Should I move to Linux? Should I look for emulation? What is best path out of this pickle:confused: Thanks for any advice.:)

sleap
03-06-2013, 03:39 AM
Stab in the dark here but have you installed the latest video drivers?


It might also be worth having a quick look at the DLLs your app uses on the other machine - search for "windows dependency walker". Probably not what you're after but it's helped me with things like a libpng version mismatch or figuring out which visual studio runtimes I need.

elisokal
03-06-2013, 05:03 AM
Stab in the dark here but have you installed the latest video drivers?


It might also be worth having a quick look at the DLLs your app uses on the other machine - search for "windows dependency walker". Probably not what you're after but it's helped me with things like a libpng version mismatch or figuring out which visual studio runtimes I need.

Thanks. I have since decided to host my app (www.3Delighted.net) on Windows 7. The issues on the server OS's seemed impenetrable.