PDA

View Full Version : OpenGL and Mesa for MythTV



Quantum
02-12-2013, 10:43 AM
It appears that hardware accel is working on my machine, but it still shows the pesky Mesa. I've deinstalled everything Mesa-related that won't destroy my system, but it stubbornly stays. nVidia Quadro FX 2800M with manually-installed binary driver.

What is this, and how can I fix it?

skeezix6
02-12-2013, 12:01 PM
You are running inside a VMware virtual machine.

Quantum
02-12-2013, 03:24 PM
No, this is actually on the main machine. I don't even have VMware installed. I run x2go. This is an HP EliteBook 8740w notebook.

And I get a very similar string on my HTPC, which is an Asus ATX mobo with built-on nVidia 9300 chip. Again, right on the hardware and no VMware installed.

Hm, I read that llvmpipe means it's doing software rendering.

In Xorg.0.log I find:

Failed to initialize the GLX module; please check in your X
log file that the GLX module has been loaded in your X
server, and that the module is the NVIDIA GLX module. If
you continue to encounter problems, Please try
reinstalling the NVIDIA driver.
Well, this -is- the X log file. Further up it says:
Loading extension GLX(EE) NVIDIA(0):
... but no version number or other info, as if it can't find the module.

I'm compiling the nVidia driver manually, not using the one from the repo.

Why would it not be finding GLX?

Dark Photon
02-12-2013, 04:18 PM
> lsmod | grep nvidia

> grep nvidia /etc/X11/xorg.conf

> ldd `which glxinfo`

> ls -l /usr/lib/libGL.so.1 /usr/lib64/libGL.so.1

Quantum
02-12-2013, 04:59 PM
Thanks but I've found the problem. xorg wasn't able to load the GLX extension for the compiled nVidia driver, because the X development files were not installed! I installed the metapackage xorg-dev, rebooted into recovery, recompiled the video driver, rebooted, and now by Jove I get this:

# glxinfo
...
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro FX 2800M/PCIe/SSE2
OpenGL version string: 3.3.0 NVIDIA 310.32
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
...

Only thing is, now glxgears is back down to ~60fps. With the VMware software driver I was getting 500fps. Any idea why?

Dark Photon
02-12-2013, 05:04 PM
> env __GL_SYNC_TO_VBLANK=0 glxgears

You likely have an LCD monitor, which refreshes at 60Hz, and sync-to-vblank is on by default.

nvidia-settings under GPU 0 (CRT-0 tab here) will tell you what its got the refresh rate set to. Here I get 97Hz (I'm not on an LCD).

Quantum
02-13-2013, 09:27 AM
Nice, thanks. Yep, 59.95Hz on LCD.

One more thing DP: I run XFCE, and on darker themes I get a noticable flickering. It's much slower than 60Hz, I'd say about 10 or 20. Giving me a headache.

Could this be caused by sync-to-vblank? Or something else?

Dark Photon
02-13-2013, 11:16 AM
Don't know. If XFCE doesn't use OpenGL for rendering, then OpenGL sync-to-vblank isn't in play. XFCE may not be double buffering or synchronizing its swap to vertical retrace.