PDA

View Full Version : The Anger Spill



Atomic_Sheep
11-13-2012, 03:09 AM
2 days and getting to a point where I want grab objects and throw them at the blooming walls and headbutt my own face. Have a program that opens a window and loads a bmp image. Everything works fine. So I go and create a new one, to be able to open another window and load another image. White screen!!!!!!! Copy pasted everything as from the other program, white screen. Loaded the image that I'm trying to load into the new program into the first program, no problems, totally compatible, no dramas. HOW THE HELL can this be? 2 days later and STILL this program won't run. At a point of just giving up on programming for good to be honest. Every bug takes days to find. This one though, tops them all. UNBELIEVABLE!!!!

P.S. Definitely nothing wrong with the code, it's the sun's fault.

Kopelrativ
11-14-2012, 12:37 AM
You seem to be in for an unusually stubborn situation. I think everyone doing OpenGL has been through this, and sometimes you see the mention of the "black screen of death". There are just too many global states that can go wrong.

My lessons learned is to start with something simple that works, and then always do all changes very small, step by step. Sometimes, I get overconfident, and have to revert back to an intermediate state where it starts to work again.

I am sure you will soon find a silly small mistake somewhere. It turns out it is unusual that it is a bug in the build environment or the drivers.

Carmine
11-14-2012, 01:09 PM
Please - don't hurt yourself. Post your code or a simplified version of it.