View Full Version : Help setting up glsdk

05-22-2012, 03:19 PM
First, the problem I have is an error in VS 2010 when I try to run "Hello Triangle" tutorial by Jason L. McKesson. The error is: LINK : fatal error LNK1104: cannot open file 'glloadD.lib'

Now, up to this point I've done the following:

I downloaded and unpacked Premake4.
I downloaded and unpacked glsdk 0.4.2
I opened the directory from the command line and ran premake4 for vs2010. Following is the output:

C:\glsdk_0.4.2>cd examples

C:\glsdk_0.4.2\examples>premake vs2010
'premake' is not recognized as an internal or external command,
operable program or batch file.

C:\glsdk_0.4.2\examples>premake4 vs2010
Building configurations...
Running action 'vs2010'...
Generating examples.sln...
Generating caustics/caustics.vcxproj...
Generating caustics/caustics.vcxproj.user...
Generating caustics/caustics.vcxproj.filters...
Generating simple_glfw/simple_glfw.vcxproj...
Generating simple_glfw/simple_glfw.vcxproj.user...
Generating simple_glfw/simple_glfw.vcxproj.filters...
Generating simple_glut/simple_glut.vcxproj...
Generating simple_glut/simple_glut.vcxproj.user...
Generating simple_glut/simple_glut.vcxproj.filters...

After running that, I downloaded the tutorials (tutorial 0.3.8 and tutorial 0.3.7) and unpacked them. Then I ran premake from their source directories. I received the following output:

C:\OpenGL Tutorials\Tutorial 0.3.8\Tut 01 Hello Triangle>premake4 vs2010
Building configurations...
Running action 'vs2010'...
Generating Tutorial1.sln...
Generating ../framework/framework.vcxproj...
Generating ../framework/framework.vcxproj.user...
Generating ../framework/framework.vcxproj.filters...
Generating Tut 01 Main.vcxproj...
Generating Tut 01 Main.vcxproj.user...
Generating Tut 01 Main.vcxproj.filters...

Now, I don't have any experience using makefiles and their programs, so maybe this is the problem. First, I opened the solution for "Hello Triangle" and tried to run it. I received the missing lib error. Then I read a little and determined maybe I had to do something with the sdk files. So I opened the solution file and built all of the projects in VS2010. All builds were successful, and when I build now, it says they are all (6 of them) up to date. I then found glsdk examples, ran premake, and opened the solutions for the examples -- they were built and ran successfully. I saw a floating sphere which appeared to be under water, and I saw two triangles. However, when I try to run "Hello Triangle," I still get the lib error. The full text follows:

1>------ Build started: Project: framework, Configuration: Debug Win32 ------
1>Build started 5/22/2012 4:14:47 AM.
1> Creating "lib\Debug\framework.unsuccessfulbuild" because "AlwaysCreate" was specified.
1> All outputs are up-to-date.
1> All outputs are up-to-date.
1> framework.vcxproj -> C:\OpenGL Tutorials\Tutorial 0.3.8\framework\lib\frameworkD.lib
1> Deleting file "lib\Debug\framework.unsuccessfulbuild".
1> Touching "lib\Debug\framework.lastbuildstate".
1>Build succeeded.
1>Time Elapsed 00:00:00.15
2>------ Build started: Project: Tut 01 Main, Configuration: Debug Win32 ------
2>Build started 5/22/2012 4:14:48 AM.
2> Touching "obj\Debug\Tut 01 Main.unsuccessfulbuild".
2> All outputs are up-to-date.
2> All outputs are up-to-date.
2>LINK : fatal error LNK1104: cannot open file 'glloadD.lib'
2>Build FAILED.
2>Time Elapsed 00:00:02.05
========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

In case it isn't clear, I'm running VS 2010 (not express) on Windows 7 Professional with a GForce 9500 GT card running DirectX 11.



Alfonse Reinheart
05-22-2012, 07:01 PM
Now, up to this point I've done the following:

You seem to have missed a step or two from the instructions. (http://www.arcsynthesis.org/gltut/Building%20the%20Tutorials.html)

First, you don't download the SDK if you're trying to build the tutorials; it comes with the tutorials. Second, you never actually built the SDK; you build the SDK's examples. The instructions state:

So, with premake4.exe in your path, go to the glsdk directory. Type premake4 plat, where plat is the name of the platform of choice.

Emphasis added.

So try it that way.

05-22-2012, 07:59 PM
Thanks so much! That's exactly what the problem was! I'm looking forward to working through the book!