PDA

View Full Version : Is a dark theme for OpenGL desirable?



Khronos_webmaster
04-27-2012, 08:00 AM
A dark theme has been requested a couple of times in the past, and again in since we upgraded. We are curious if you would like to have a dark theme?

tksuoran
04-27-2012, 08:11 AM
Yes please.

Before upgrade there was dark theme, I used it, and I was happy with it.

Strange how "Results 1 to 2 of 2" only shows 1 vote..

tanzanite
04-27-2012, 04:02 PM
Assuming (can not think of any other way to see it that would make any sense) the questions is to gauge the priority (with fairly ridiculous error margins) of adding such an option - i have to say no as i would not use it. BUT, it would be nice when there sooner or later would be such an option for thous that prefer it. Also, non-black should, obviously (or not), remain the default.

Groovounet
04-29-2012, 01:52 PM
I'll say yes as far as we keep a light theme too.

tksuoran
04-30-2012, 02:21 AM
For some people like me this is actually an accessibility issue and not just look and feel.

Dark Photon
05-01-2012, 08:00 PM
Sitting here trying forum appearance options on this 10.1" tablet, I find I really like the dark theme. Thanks for suggesting it (and for installing it).

tksuoran
05-02-2012, 07:30 AM
Looks quite good. However, quotes and code blocks are unreadable, the show white font on light gray background.

Dark Photon
05-02-2012, 10:36 AM
Can confirm that behavior here. Hopefully an easy tweak for the webmaster.

Khronos_webmaster
05-08-2012, 08:12 AM
I've adjusted the quotes and they are working here. Can you confirm if they are working there also?
Thanks.

Chris Lux
05-09-2012, 01:58 AM
quotes look fine, but code is still unreadable.

regards
-chris

thokra
05-09-2012, 10:27 AM
but code is still unreadable

In what way? Just posted some code and it looked just like the old school code.

Khronos_webmaster: While we're at it, do you intend to add some syntax highlighting goodness? ;)

Chris Lux
05-10-2012, 03:28 AM
in this thread all code is white on white:

http://www.opengl.org/discussion_boards/showthread.php/177593-Nvidia-bindless-textures-first-experiences-and-bugs?p=1237289#post1237289 (http://www.opengl.org/discussion_boards/showthread.php/177593-Nvidia-bindless-textures-first-experiences-and-bugs?p=1237289#post1237289)

thokra
05-10-2012, 03:39 AM
Yeah, I'm an idiot. I should have used the dark theme. :D

Confirmed. With the dark theme, code is not readable.

Edit: I just saw in http://www.opengl.org/discussion_boards/showthread.php/177545-open-a-context-Opengl-3-3-with-wglCreateContextAttribsARB-and-texture-probleme?p=1237400#post1237400 that some code actually is rendered in a way you can read it well, while some posts earlier the problem with "white-on-white" code also applies. Weird.

Edit 2: User profiles seem to have the same problem as code sections.

tksuoran
05-14-2012, 09:01 AM
Yeah, I'm an idiot. I should have used the dark theme. :D

Edit: I just saw in http://www.opengl.org/discussion_boards/showthread.php/177545-open-a-context-Opengl-3-3-with-wglCreateContextAttribsARB-and-texture-probleme?p=1237400#post1237400 that some code actually is rendered in a way you can read it well, while some posts earlier the problem with "white-on-white" code also applies. Weird.


I think that post simply does not use code markup.

Could we get the code markup fixed for dark theme, please?

thokra
05-14-2012, 10:59 AM
I think that post simply does not use code markup.

I think it does. Why else would it be formatted inside a box overwritten with Code: ? :)

tksuoran
05-15-2012, 03:15 AM
Oh I see now. I was looking at the post your link took me, the one by PiouPiou, while you probably meant the post by Dan Barlett.

The latter one uses COLOR=#333333 markup inside the code markup, which explains why it is readable. I guess that color markup was manually added?

Chris Lux
06-10-2012, 06:34 AM
I am sorry to bring this up again, but the dark theme is still broken in regard so code tags...

-chris

tksuoran
07-04-2012, 05:12 AM
Bump. Could you please try to fix this?

thokra
07-04-2012, 06:59 AM
What's still broken for you? The code tags seem to work fine now. So do comments and normal text.