PDA

View Full Version : installing freeGLUT in Lion



emmanuel_f
02-22-2012, 12:45 AM
Hello there!

I am trying to install freeGLUT in Lion. I am following the next steps:
./autogen.sh
CPPFLAGS="-I/usr/X11R6/include" ./configure --prefix="${PWD}/../"
make
make install

first two steps fine, but when i make the make or the make install i got the next error:
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make[2]: *** [libglut.la] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

not sure if i am doing something wrong or this a software issue. Any ideas?

computer spec:
OSX Lion 10.7.3
NVIDIA GeForce GT 330M 512 MB


thanks!

Jinster
03-07-2012, 06:29 PM
I am actually facing the exact same problem and there seems to be no reply to this question. I am wondering if anyone has solved this problem and generously share how?

Thanks

ZbuffeR
03-08-2012, 01:36 AM
This question would be better directed to the freeglut team it seems.
http://freeglut.sourceforge.net/

Can you investigate a bit about your arch settings ?
1) do you have a 64bits OS or not ?
2) do a "file" on your compiled .o .so .a and post results. ie :
file lib/freeglut.so
lib/freeglut.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), stripped
or :
ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), not stripped

3) do the same on the X libs installed on your system.
4) check the output of the autogen and configure steps, to check for any misdetection of your actual architecture