PDA

View Full Version : nvidia output_debug error 131185 ?



matrem
11-05-2011, 04:46 AM
Hello,

I'm under linux (ubuntu 11.10), with 285.05.09 nvidia drivers for my gtx460.

Using the debug_output extension with no filter give me this error when I use glBufferData on my first buffer (without any link to element_array_buffer ) :


error log
---------
source : GL_DEBUG_SOURCE_API_ARB
type : GL_DEBUG_TYPE_OTHER_ARB
id : 131185
severity : GL_DEBUG_SEVERITY_LOW_ARB
Buffer detailed info: Buffer object 1 (bound to GL_ELEMENT_ARRAY_BUFFER_ARB, usage hint is GL_ENUM_88e4) will use VIDEO memory as the source for buffer object operations.

Does someone understand the problem ?

ps : no problem with my ati firepro / win7 last driver (using debug_output_amd).

aqnuep
11-05-2011, 06:22 AM
This means no problem, just the driver informed you that as you specified GL_STATIC_DRAW as the storage hint to your element array buffer (that's what it tries to say with GL_ENUM_88e4) the driver will put your buffer to video memory, not system memory.

Please consider that in case you use no filtering with debug output, you can receive such reports that are not errors or warning s, just info logs. This is one example for that.

matrem
11-05-2011, 07:22 AM
Thanks.

Is debug_output a good place for log information (perhaps "other" type include that :) )?

Anyway, the strange thing is that there is nothing bound to element_array_buffer, and even if I use other usage hint, if will tell the same.

Perhaps the binding point information is buggy and my usage hint are not used because it is only a hint ?